2009-04-30

cdp/vtp & allowed vlan

вопрос:
что произойдет, если на транке отключить нативный влан, например с помощью swithport trunk allowed vlan exclude или shutdown vlan?

ответ:
1) cdp все равно работает
2) vtp все равно работает

п.с. они работают даже если на транке заблокированы ВСЕ вланы (например STP)

VTP transparent

результат тестирования работы VTP transparent catalyst 3560 ios 12.2(25)se2.
итог тестирования меня сильно смутил.

если домен не совпадает и не равен NULL апдейты не пропускаются.

версия VTP никак не влияла. то есть апдейты проходят(или не проходят) без разницы какая версия VTP настроена на транспаренте и на других свичах.

замечание: на nm-XXesw vtp ведет себя по-другому.

Question of the day

вопрос:
дан конфиг

ip vrf A
  rd 1:1
!
ip vrf B
  rd 1:2
!
int lo0
  ip vrf forwarding A
  ip add 1.1.1.1 255.255.255.255
!
int lo1
  ip vrf forwarding B
  ip add 1.1.1.1 255.255.255.255
!
int fa0/0
  ip vrf forwarding A
  ip add 10.0.1.1 255.255.255.0
 no shu
!
int fa0/1
  ip vrf forwarding B
  ip add 10.0.2.1 255.255.255.0
  no shu
!
router ospf 1 vrf A
  network 0.0.0.0 255.255.255.255 area 0
!
router ospf 2 vrf B
  network 0.0.0.0 255.255.255.255 area 0

какие Router-ID будут выбраны процессами OSPF?

ответ: предположительно ospf 1 router-id 1.1.1.1, ospf 2 router-id 10.0.2.1. Т.е. айди должны быть уникальны не только для vrf, но и для коробки.

Question of the day

вопрос:

а что будет, если был получен пакет с неверной автентификацией OSPF?

а) соседство будет прервано
б) пакет просто проигнорируется

ответ: б) проигнорируется. сосед будет удален только по истечении dead-таймера

2009-04-29

Question of the day

вопрос:

что будет, если маршрутизатор EIGRP получит от соседа хелло-пакет с неправильной информацией автентификации?

а) соседство разорвется
б) пакет будет проигнорирован

ответ: а) %DUAL-5-NBRCHANGE: EIGRP-IPv4:(279) 1: Neighbor 10.0.0.1 (Vlan1) is down: Auth failure
т.е. сразу падает.
п.с. такой хелло пакет очень легко подделать ;)

Question of the day

вопрос:
какова длина bpdu-сообщения?
сколько существует форматов bpdu-сообщений?

варианты ответов оставляйте в комментариях :)

2009-04-28

Question of the day

вопрос:
можно ли для EIGRP сделать хелло/холд таймеры меньшие чем 1 секунда?

ответ: именно для EIGRP - нет (рекомендуемый минимум 1/3 сек). но можно задействовать BFD(Bidirectional Forwarding Detection), и использовать сообщения BFD для отслеживания соседей. Недостаток: проверяется только форвардинд, т.е. сбои самого EIGRP замечены не будут (т.е. может только дополнять а не заменять хелло-протокол).

2009-04-27

Задания 3й олимпиады: часть 2, UNI

Задания категории UNI скоро появяться на сайте олимпиады, а пока они есть здесь:
в архиве .net файл для GNS3 и начальные конфиги устройств.
и текстовая часть задания.
в оригинале задание было разделено на три части, каждая следующая закрыта паролем который скрыт в топологии, т.е. для перехода к ней нужно выполнить задание предыдущей.

некоторые замечания: возможно в стартовых конфигах не сохранились данные VTP - вланы надо будет создать наново. так же в конфигах нет содержимого флеша - файлов с паролями для следующих этапов.

Задания 3й олимпиады: часть 1, PT

На сайте олимпиады появились задания для категории PT: http://cisco-olymp.org.ua/pt.rar.
или здесь:
pdf - текстовая часть заданий.
pka - файл PacketTracer5 с топологией и начальными конфигами.

Question of the day

вопрос:

если на транковом соединении заблокировать native-vlan, которые из перечисленных протоколов будут работать: CDP, VTP, DTP, LLDP.

пишите ваши варианты ответов в комментариях (желательно указывать на чем проверяли(модель/иос) :))

Question of the day

вопрос:

дан конфиг:

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 10.0.1.1 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 10.0.1.1 0.0.0.0 area 0
!
router ospf 2
 log-adjacency-changes
 network 10.0.0.1 0.0.0.0 area 0

какие router-id будут у обоих процессов OSPF?

ответ:

sh ip ospf | in ID
 Routing Process "ospf 2" with ID 10.0.1.1
 Routing Process "ospf 1" with ID 1.1.1.1

айди должны быть уникальны, потому айпи лупбека используется только 1 раз :)

2009-04-26

Question of the day

эксперимент: вопрос к которому ответ не указан сразу. свои догадки/ответы оставляйте в комментариях. автору самого красивого ответа (а таких ответов может быть несколько) - мои поздравления и уважение :)

вопрос: как можно отключить Spanning-Tree на порту коммутатора?

Question of the day

вопрос1:

можно ли изменять(редактировать) списки доступа(acl) ip?

ответ1: да, можно. для этого надо использовать режим ip access-list standart|extended |, и в этом режиме использовать no для удаления записи под определенным номером из списка, и для добавления записи в определенное место acl.

вопрос2: то есть можно редактировать и стандартные и расширенные списки доступа?

ответ2: да, но для стандартных нельзя вставлять записи в средину списка, они всегда будут добавляться в конец (это баг такой, а не фича).

2009-04-25

третья студенческая олимпиада Cisco в Украине

вчера, 24 апреля, в Центре Знаний прошел финал олимпиады.
в нем приняли участие 30 студентов сетевых академий в двух категориях, по 15 человек в каждой.

задания были достаточно сложными, несмотря на то что опирались сугубо на уровень курса CCNA, и каждый из участников имел возможность проявить свои знания, смекалку и скорость.

подробнее о финалистах и победителях - http://cisco-olymp.org.ua 

Question of the day

вопрос:
сколько инстанций RIPng можно создать на 1м маршрутизаторе с IOS 12.4T?

ответ: предположительно 4:

Router(config)#ipv router rip r1
Router(config-rtr)#ipv router rip r2
Router(config-rtr)#ipv router rip r3
Router(config-rtr)#ipv router rip r4
Router(config-rtr)#ipv router rip r5
% Too many RIP processes
% Failed to create routing protocol rip


но документальных подтверждений я к сожалению не нашел, может это зависит от версии иос и платформы...

2009-04-23

Question of the day

вопрос:
подымется ли соседство eigrp, если на двух сторонах линка между роутерами разный mtu?

ответ: в принципе да. все что измениться это атрибут mtu у маршрутов.

Question of the day

вопрос:
какая нынче актуальная версия протокола eigrp?

ответ: версия 2. по-крайней мере если верить полю version и tcpdump и wireshark.

2009-04-22

Question of the day

вопрос:
можно ли пустить etherchannel через QinQ туннель?

ответ: конечно же можно. но крайне желательно для каждого тунеля делять соединение точка-точка, и желательно отдельным вланом. а то lacp и pagp с ума сойдут от мультипойнт топологии :)

Question of the day

вопрос1:
можно ли Port-Security повесить на транковый порт?

вопрос2: а на dot1q-tunnel порт?

ответ1: ну да, лишь бы static trunk (not dynamic) 

ответ2: ну да

2009-04-21

Question of the day

вопрос:
а как будет меняться метрика EIGRP, если K-коефициенты изменены?

ответ: можно посчитать по формуле, иногда даже не измениться (к3=0) :)

Question of the day

вопрос:
как изменяет offset-list композитную метрику EIGRP?

ответ: изменяется лишь задержка, с таким расчетом что при умолчательном значении K3 суммарная метрика измениться за заданное значение offset-value.

2009-04-20

Question of the day

вопрос:
совместно с какими протоколами маршрутизации можно использовать offset-list?

ответ: с дистанс-векторными, а точнее с RIP или EIGRP.

Question of the day

вопрос:
можно ли на Cisco IOS device (не аса, не марс) сделать полнотекстовый снифф пакетов (а-ля tcpdump)?

ответ: в принципе да. вопрос2: как?

ответ2: debug ip packet [ACL] detail
dump

2009-04-19

Question of the day

вопрос:
сколько нужно команд для того что бы очистить конфигурацию Cisco IOS device?

ответ: приблизительно две. вопрос2: каких?

ответ2-1: 
# write erase ! или delete startup-config
# reload

ответ2-2:
# write erase ! или delete startup-config или создать любой пустой файл на флеше либо нвраме (например с помощью tcl)
# configure replace nvram:startup-config ! или указать свой пустой файл

Question of the day

вопрос:
сколько классов можно задать для политики QoS с помощью MQC?

ответ: 255+class-default, итого 256

2009-04-18

Question of the day

вопрос:
что произойдет, если при настройке etherchannel между двумя свичами, с одной стороны на строить channel-mode on, а с другой настройку пропустить?

ответ: не знаю.

Question of the day

вопрос:
что будет с базой вланов, если свич vtp-client отключить от vtp-сервера, и перезагрузить?

ответ: собственно ничего... vtp client вопреки doccd хранит вланы в vlan.dat на флеше

2009-04-17

Question of the day

вопрос:
switch# conf t
switch(config)# vtp domain cisco
switch(config)# vlan 10
switch(config-vlan)# vlan 20
switch(config-vlan)# no vlan 20
<----T1---->
switch(config)# vtp mode transparent
switch(config)# vlan 30,40,50
switch(config-vlan)# vlan 60
switch(config-vlan)# no vlan 30
<----T2---->
какие будут номера ревизий vtp в моменты времени T1 и T2?

ответ: T1=3, T2=0

Question of the day

вопрос:
делит ли оспф трафик поровну между линками с равной стоимостью?

ответ: конечно же нет! :) задача оспф - выдать лучшие маршруты. делить трафик будет уже кто-то другой, и как - не известно(например, см. CEF).

2009-04-16

Question of the day

вопрос:
что будет, если все k-коефициенты eigrp установить в 255 на всех маршрутизаторах?

ответ: соседи будут очень смешно каждый hello-интервал писать Goodbye received (см. Graceful Shutdown)

Question of the day

вопрос:
что будет, если все k-коефициенты eigrp установить в 0 на всех маршрутизаторах?

ответ: мы получим очень быстрый RIP :) выбор маршрутов будет происходить по хопкаунту, зато будет использоваться гибридный протокол маршрутизации

Question of the day

вопрос:
маршрут в сеть Х получен с помощью RIP, OSPF и EIGRP. для каждого протокола выполнена команда distance 100 ...
сколько маршрутов будут использоваться для балансировки трафика в сеть Х?

ответ1: один. вопрос2: а какой?

ответ2: тот у которого АД ниже. или АД по-умолчанию ниже. т.е. eigrp.

2009-04-15

Question of the day

вопрос:
какой интервал отправки апдейтов у ODR?

ответ: от 5 до 254 секунд. по-умолчанию 60. см cdp timer

Question of the day

вопрос:
а в eigrp?

ответ: наверно 2 (обычные с hello 5 dead 15, и nbma(encapsulation frame-relay) с hello 60 dead 180)

Question of the day

вопрос:
сколько типов сетей бывает в оспф 2.0?

ответ:6 (broadcast, non-broadcast, point-to-point, point-to-multipoint, point-to-multipoint non-broadcast, loopback)

Question of the day

вопрос:
у роутера R1 три соседа: R2,R3,R4.
необходимо сделать так, что бы запись соседства R1 держалась в таблице CDP 5 минут после последнего полученого сообщения CDP. Сколько для этого необходимо команд?

ответ1: нисколько. максимальное значение холд-таймера 255 (секунд)

ответ2: если бы холд-таймер можно было бы установить в 300 секунд, то нужна была бы ровно 1 команда на R1: cdp holdtimer 300

Question of the day

вопрос:
чем отличается eigrp версии 0 от eigrp версии 1?

ответ: как минимум значением поля version в заголовке пакетов :)